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INTRODUCTION 

The purpose of this manual is to introduce the more intermediate techniques available in 
Excel 2000 for users who would like to increase their knowledge of this wonderful 
spreadsheet programme.  These Topics have been chosen for their relevance to work 
covered by NHHG. 

There is now an Excel Advanced course, and a separate manual containing the topics 
covered on that course. 

If you require more detailed instructions, or a wider range of topics, a full set of the 
Microsoft Office standard User Manuals is available in each office. 

 

HOUSEKEEPING 

Files created from Excel 2000 should be stored on the network - this reduces the need 
to save or backup files onto floppy discs. You can obtain the names of your network 
drives from your colleagues, or you can request extra drives - in writing - from IT. 

It is important that you save to the network drives as backups of information will take 
place daily. This reduces the likelihood of file loss via machine failure or theft. 

Remember to delete old and unwanted files to free up memory on the network. 
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FORMULAE 

INTERMEDIATE FUNCTIONS 

You should already be familiar with the SUM function, used to total a range of cells.  
Here are some other functions that can be useful.  In these examples, all the formula act 
upon the range of cells from B5 to B10 inclusive. 

Formula Result 

=SUM(B5:B10) Calculates the total of the cells in the range 

=AVERAGE(B5:B10) Calculates the average of the cells in the range 

=MAX(B5:B10) Displays the maximum value in the range 

=MIN(B5:B10) Displays the minimum value in the range 

=COUNT(B5:B10) Counts the number of cells that contain numbers 
in the range 

=COUNTBLANK(B5:B10) Counts the number of blank cells in the range 

 

Apart from the SUM function, there is no toolbar button that can be used to automatically 
create these formulae.  Each formula has to be typed manually into a cell.   

 

☺TIP  
When creating formula, as a shortcut, once you have typed the first opening 
bracket you can then click and drag through the range of cells you wish the 
function to act upon.  Then type the closing bracket and press [Return]. 
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THE IF FUNCTION 

This function can be used to test the contents of a cell and then perform two different 
actions depending on the result of the test.  The function is split into three parts - the 
condition to test, the action to perform if the test result is true, the action to perform if the 
test result is false. 

i.e. =IF(Condition to Test, Action if True, Action if False) 

The ‘Condition to Test’ tests the contents of a cell.  It can test a numerical value or a 
text string.   

The conditional operators used to test the cell contents are: 

Operator Comparison 

= Equal to 

> Greater than 

< Less than 

>= Greater than or equal to 

<= Less than or equal to 

<> Not equal to 

 

The ‘Action if True’ and the ‘Action if False’ are used to perform a calculation, display 
a number or display some text. 

If text is being tested or displayed, it must be entered into the formula in inverted 
commas, i.e. “Grove House” 

Here are some examples: 

=IF(B5>100,B5*D10,B5*D11) If cell B5 is greater than 100, then B5 is multiplied 
by D10, otherwise it is multiplied by D11 

=IF(D4<0,”Overdrawn”,”Credit”) If cell D4 is less than zero, then the word 
Overdrawn is entered, otherwise the word Credit 
is entered 

=IF(B5=“London”,100,”External”) If cell B5 contains (only) the word London, then 
the number 100 is entered, otherwise the word 
External is entered 

=IF(SUM(B5:B10)=SUM(E5:E10),
”Correct”,”Error”) 

If the sum of the cells B5 to B10 is equal to the 
sum of the cells E5 to E10, then the word Correct 
is entered, otherwise the word Error is entered 

 

Here are some examples of the 
‘Condition to Test’.   
These are all testing the 
contents of cell B5. 
 
B5=B10 
B5=“London” 
B5>1000 
B5<SUM(C5:C12) 
B5<>0 
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The format must be followed exactly, all commas, brackets and quotation marks must be 
included for the formula to work 

ABSOLUTE CELL REFERENCES 

Absolute Referencing is a facility which allows cell references to be fixed in a formula, it 
is particularly relevant when formulae are copied from one location to another - via any 
of the methods available in Excel. 

When copying to repeat formula, if one cell contains a formula to add B3:B7 and you 
copy that formula across to columns C and D. It will upgrade and produce formulae to 
total the C and D ranges ie, add C3:C7, D3:D7 etc. 

There are times when you do not want a formula to adapt when it is copied to another 
location. It is in these cases that you use an "Absolute Cell Reference". 

This means that the reference for this cell remains fixed or "Absolute". 

For example, if you are always going to multiply totals by a rate of inflation, which is held 
in a single cell reference. You will not want the reference to change as you copy the 
formula, otherwise the formula will not be able to find the rate of inflation, therefore you 
must fix the location of the inflation cell in the formula using Absolute Referencing. 

An Absolute may apply to a single cell reference in a formula, or to all the cell references 
depending on the function the formula is set to achieve. 

INSERTING ABSOLUTE REFERENCES 

To confirm an absolute reference the "$" sign is used. It is inserted in the reference 
before the column and row numbers e.g. $A$4 and can be inserted manually [Shift] [4], 
or automatically using the [F4] key. You can repeat this process independently for each 
“Absolute” reference in a formula. 

For example, the rate of inflation in your formula =(SUM(B3:B7)*A4) is held in cell 
reference A4 and you want this fixed in the formula no matter where you copy it to. 

• Commence your formula and at the point you type A4 press [Shift] [4] to prefix 
each character with a $ sign one before the A and one before the 4. E.g. $A$4 

or 

• Type the cell reference and press [F4], $ signs will be added to the reference. 

Your formula now shows as “=(SUM(B3:B7)*$A$4)” 

If copied to the “D” column the formula will upgrade to reflect the move becoming 
“=(SUM(D3:D7)*$A$4)” but retaining its integrity in pointing to the inflation cell A4. Thus 
the new total is calculated but it is affected by the fixed cell. 

It is likely that you may only wish only one character in a cell reference to be fixed. 

E.g. A4, B4 and C4 may hold differing rates of projected inflation for 4 financial years. 
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• The consistent character here is 4. Therefore you would set the $ sign only 
before the 4, that will fix the line number and allow the column letter B, C etc. to 
upgrade. E.g. A$4, B$4, C$4 

 

Absolutes And AutoFill 

Absolute references are particularly useful when you are using "AutoFill" to repeat a 
formula over a range of cells. Always consider the use of Absolutes when copying 
formulae via AutoFill as this is the function most likely to generate incorrect references in 
bulk and therefore the majority of problems. 

AMENDING OLD FORMULA TO CONTAIN ABSOLUTES 

If a formula has been created and you wish to amend the cell references or part of a cell 
reference to an absolute: 

• Locate the insertion point in the formula bar at the cell reference and click 

• Press [F4] once, both characters of the cell reference will be amended to an 
absolute with $ signs, e.g. $E$4 

• Press [F4] twice, the row number of the cell reference will be amended to an 
absolute with a $ sign, e.g. E$4 

• Press [F4] 3 times the column letter of the cell reference will be amended to an 
absolute with a $ sign, e.g. $E4 

• Press [F4] 4 times and both characters of the cell reference will return to normal, 
e.g. E4 

Alternatively, for a single character it may be easier to simply insert the $ sign manually 
before the relevant character. 

 



www.ebitsolutions.net     JANUARY 2000 EBIT SOLUTIONS LIMITED 
 

 
6 EXCEL 2000 INTERMEDIATE USER MANUAL 

THE FORMAT PAINTER TOOL 

The Format Painter Tool is used to copy formatting from one cell and then to apply that 
formatting to another cell without changing the cell contents.  This works for all 
formatting - bold, italics, size, font, alignment, number style, border, cell colour, etc. 

To Copy And Paste Formatting 

• Select the cell containing the formatting you want to copy 

• Click on the “Format Painter” button 

 

• Select the cells you want to paste the formatting to 

This method allows you to apply the formatting only once.   

 

 

It is possible to apply the formatting to several different ranges of cells. 

To Copy And Paste The Formatting More Than Once 

• Select the cell containing the formatting you want to copy 

• Double click on the “Format Painter” button 

 

• Select each range of cells you want to paste the formatting to 

• Click on the “Format Painter” button to turn the feature off 
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AUTOFILL 

Apart from the standard AutoFill facilities, there are other functions available in the 
AutoFill set up. 

ADDITIONAL FEATURES 

• Click and drag the area to be AutoFilled with the RIGHT mouse button. 

When you let go, a selection of other functions will be displayed, the functions  offered 
will vary depending on the contents of the original cell. 

•  “Copy Cells” replicates ALL contents-text and formats 

• “Fill Series” will increment by one unit 

• “Fill Formats” will copy the format but not text 

• “Fill Values” will copy the text but not formats 

• “Fill Days, Weekdays, Months and Years” are offered 
as appropriate if the cell holds a Day, Month or Year  

• “Linear Trend”, “Growth Trend” and “Series”, develop 
the AutoFill to accommodate a growth factor in selected 
units. Set up the first two cells as the steps of growth 
then drag to extend the series. 

 

CUSTOMISING AUTOFILL SERIES 

If you have a specific series you wish to include in the AutoFill you can create custom 
lists to use on all worksheets. 

• In the “Tools” menu choose 
“Options” 

• Click on the  “Custom Lists” 
tab 

• Click in the “List Entries” box 
and type in the contents of 
your customised list pressing 
[Return] after each entry 

• Click on the “Add” button, then 
“OK”  

 
• To use the Custom List, type the first entry on the list into the cell, then drag 

(in the normal way using the left mouse button).  The series will be expanded 
across the cells as it was originally typed into the list. 
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PASTE SPECIAL 

Paste Special allows you to control how data is copied and pasted. 

PASTE OPTIONS 

The Paste options, in Paste Special, can be used to copy and paste part of the 
information stored in a cell.  A normal ‘copy and paste’ copies the cell contents and 
formatting.  But with Paste Special you can copy the formatting without the contents, the 
contents without any formatting, or even just the result of a formula (its value). 

To Copy And Paste Part Of The Information In A Cell 

• Select the cell(s) to copy 

• Click on the “Copy” button 

• Click on a cell to choose the paste area 

• In the “Edit” menu select “Paste Special” 

This will bring up the Paste Special dialog box. 

 

In the Paste options: 

• Select Formulas to paste the contents or formulas without the formatting 

• Select Values to paste the results of a calculation as a number, not a formula 

• Select Formats to paste the formatting, but not the cell contents 

• Select Notes to paste the Notes, but not the cell contents or formatting 
(See section on adding Notes to cells) 

• Click “OK” 
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SKIP BLANKS 

The Skip Blanks option is used when you are pasting one set of data over another.  If 
there are blank cells in the copied data, the corresponding cells in the paste range will 
continue to contain their original data. 

PASTE OPERATIONS 

Paste Special can also be used to add, subtract, divide or multiply a range of cells by 
any one number.  This is useful if, for example, you need to divide a large range of cells 
by 100 before you apply the percentage number style to them. 

To Use A Paste Operation 

• Select the cell containing the number you wish to add, subtract, multiply by or 
divide by 

• Click on the “Copy” button 

• Select the cells you wish to operate on 

• In the “Edit” menu select “Paste Special” 

In the Paste Special dialog box 

• Select an Operation - Add, Subtract, Multiply or Divide 

• Click “OK” 

TRANSPOSE 

Paste Special also has a transpose feature that allows you to change the way a table of 
data is arranged. 

This is the effect of transposing data: 

Original Data  Transposed Data 

 1996 1997   Rent Travel Loan Food 

Rent £3,650 £3,100  1996 £3,650 £220 £500 £1,500 

Travel £220 £245  1997 £3,100 £245 £300 £1,650 

Loan £500 £300       

Food £1,500 £1,650       

 

To Transpose Data 

• Select the data 

• Click on the “Copy” button 

• Click on a cell to choose the paste area 

• In the “Edit” menu select “Paste Special” 

In the Paste Special dialog box 
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• Select “Transpose” 

• Click “OK” 

COPY AND PASTE TO WORD 

The high level of compatibility between Windows applications makes it very easy to 
incorporate Excel data into a Word document.  As a general rule anything that can be 
selected in any program can be copied and pasted into Word. 

To Copy Data To Word 

• In Excel, select the cells you wish to copy 

• Click on the “Copy” button  

• Use the [Alt]+[Tab] command to move to Word 

• Click in the document to select the position of insertion 

• Click on the “Paste” button 

The data will be inserted as a Word table.  You can now use all the Word table features 
to format the data. 

If you need to perform further calculations on the data, you should return to Excel to 
make the necessary changes.  Then copy and paste the data back into Word. 

COPYING EXCEL CHARTS INTO WORD 

If you have created an Excel chart, you can copy and paste it into a Word document. 

• In Excel, click once on the chart to select it 

• Click on the “Copy” button  

• Use the [Alt]+[Tab] command to move to Word 

• Click in the document to select the position of insertion 

At this point you can use the “Paste” command to copy in the chart.  But Excel does not 
always handle this process very well.  It may paste in a piece of the spreadsheet as well 
as the chart.  It is better to paste the chart in as a picture rather than as part of a 
spreadsheet. 

• In the “Edit” menu, select “Paste Special” 

• In the Paste Special dialog box, select “Picture” 

• Click “OK” 

To Resize The Chart 

• To resize the chart in proportion, click and drag on one of the corner selection 
handles 
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If you wish to edit the chart you should return to Excel, make the necessary changes, 
then copy and paste the chart back into Word. 

USING MULTIPLE SHEETS IN YOUR WORKBOOK 

Your Excel 2000 file is a Workbook containing a number of Worksheets. 

A default Workbook contains 3 separate Sheets. You can add, delete, copy and move 
Sheets either inside a Workbook or between Workbooks. 

The Worksheet system allows you to store information on separate Sheets rather than 
spread all over one Sheet.  You can then rename each Sheet to make it easy to identify 
the information it contains.  You can also create formulae that link cells across Sheets 
within a Workbook, or between different Workbooks. 

SELECTING A SHEET 

 

• At the bottom of the screen, click on the tab representing the Sheet you want to 
move to, the tab of the Sheet will turn white. 

If there are a lot of Sheets in the work book and you cannot see all the tabs 

 Click on the arrows to scroll left or right till you can see the tab for the 
Sheet, then click on the tab. 

RENAMING SHEETS 

• Double click on the tab of the Sheet to be named 

• Type in the new name up to 31 characters, then click on “OK” 

DELETING SHEETS 

• Right Click on the Sheet tab to be deleted 

• Click on “Edit” in the menu bar, then click on “Delete” 

A dialogue box will appear asking you to confirm the delete as any information held will 
disappear with the Sheet.  Click on “OK”. 

  

ADDING EXTRA SHEETS 

• Click on “Insert” in the menu bar, then click on “Worksheet” 

The new Sheet will be inserted to the left of the Sheet currently selected. 
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MOVING SHEETS IN A WORKBOOK 

You can change the position of Sheets and re-organise your Workbook. 

• Click on the Sheet tab and drag it across the other Sheet tabs 

A black triangle marks the position of the Sheet. 

• Drop the Sheet between two other Sheet tabs 

 

COPYING A SHEET IN A WORKBOOK 

You can replicate a Sheet inside a Workbook. 

• Hold down the [Ctrl] key and click on the Sheet to be copied. The cursor will 
acquire a “page” icon on its tip 

• Drag the icon to drop a copy of the Sheet to another location in the Workbook 

 

MOVING AND COPYING SHEETS BETWEEN WORKBOOKS 

In order to move or copy between Workbooks it is necessary to have both books open 
on screen. 

• Open both Workbooks then click on “Window”  

• Click on “Arrange”, then click on “Tiled”, then click “OK” 

Each book will use approximately half the screen and you will be able to see the tabs for 
the Sheets at the bottom of the screen. 

Moving Sheets Between Workbooks 

• Click on the Sheet tab, the cursor will acquire a “page” icon on its tip 

• Drag the icon and drop the Sheet in the other Workbook 

Copying Sheets Between Workbooks 

• Hold down the [Ctrl] key and click on the Sheet tab. The cursor will acquire a 
“page” icon on its tip 

• Drag the icon and drop a copy into the other Workbook 
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WORKING WITH MULTIPLE SHEETS 

Normally you work on one Sheet at a time.  However Excel 2000 allows you to group 
multiple Sheets together and work on them simultaneously. You can enter data, edit 
text, format presentation and create formulae in several Sheets at the same time, saving 
time and reducing errors.  

In order to edit Sheets in a group you have to select the tabs for the Sheets. 

Once the group is selected, EVERYTHING you do on ANY of the Sheets will 
happen to ALL THE SELECTED SHEETS in the group 

When you have a group of Sheets selected - If you enter data into a cell, it will be 
entered into the same cell in all the selected Sheets.  The formatting you apply to a cell 
will be applied to the same cell in all the selected sheets.  The Page Setup options you 
select will be applied to all the selected Sheets. 

SELECTING MULTIPLE SHEETS 

• Press the [Ctrl]] key and hold it down, then click on each Sheet in turn 

• The selected Sheet tabs will turn white 

 

SELECTING ADJACENT SHEETS 

• Click on the tab of first Sheet you want 

• Hold down the [Shift] key, then click on the tab of the last Sheet 

 

SELECTING ALL THE SHEETS IN THE WORKBOOK 

• Point the cursor at any tab in the Workbook 

• Click with the “Right Mouse” button, a menu will appear 

• Click on “Select All Sheets” 

DESELECTING SHEETS IN THE GROUP 

• Click on a Sheet that is not included in the group 

or 

• Click with the “Right Mouse” button, a menu will appear 
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• Click on “Ungroup Sheets” 

LINKING MULTIPLE WORKSHEETS WITH FORMULAE 

It is possible to link both Sheets and whole Workbooks with active formulae, this allows 
you to summarise information, or build compound formulae across Sheets. Any changes 
made to the data are reflected immediately in the formulae links. 

Links can be constructed to and from any cell on the Worksheet or Workbook. 

LINKING TWO SHEETS 

• Click on the cell in the Worksheet where you wish the result to appear 

• Type an “=“ sign 

• Click on the tab of the Sheet containing the cell you want linked 

• Click on the cell to link to then press [Return] 

 
You will return to the Worksheet containing the result - the two Sheets are now linked, 
the active cell will have moved to the row below your result cell. 
 
The formula bar will display the name of the Sheet and the 
cell reference of that Sheet. 

 
 

TO ADD CELLS ACROSS SEVERAL SHEETS 

 
• Click on the cell in the Worksheet where you wish the result to appear 

• Type an “=“ sign 

• Click on the tab of the Sheet containing the cell you want linked 

• Click on the first cell you wish to add 

• Type a “+” sign 

• Click on the tab of the Sheet containing the next cell you want linked and click 
on the cell you wish to add 

• Repeat the procedure for each cell you wish to add, then press [Return] to 
complete the formula 

The formula bar will display the names of all the 
Sheets and their cell references.  

 
You can also use this method to subtract, divide and multiply cells in different Sheets. 
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ADDING THE SAME CELL ACROSS SHEETS IN A WORKBOOK 

You can use the SUM function to add the same cell across a number of consecutive 
Sheets. 

• Click on the cell in the Worksheet where you wish the result to appear 

• Type =SUM( 

• Click on the tab of the first Sheet you want linked 

• Hold down the [Shift] Key and click on the tab of the last Sheet you want linked 

• Click on the cell that you wish to be added across all the Sheets 

• Press [Return] 

 

You will return to the Worksheet containing the result - the Sheets are now linked, the 
active cell will have moved to the row below your result cell. 

 

The formula bar will display the range of names of the 
linked Sheets and the relevant cell reference. 
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ADDING NOTES TO A CELL 

If you have set up a cell with a complicated formula or for a specific purpose, you may 
wish to explain how or why you have constructed the cell in a particular way.  Notes can 
be added to the cell, to be read by the user of the Worksheet to increase their 
understanding. 

The note is hidden under the cell and must be accessed through the Insert menu.  But a 
small red dot is shown at the top of the cell to tell you a note has been created. 

CREATING THE NOTE 

• Click on the cell to which the note is to be added 

• Click on “Insert” then click on “Comment”, the following comment box will 
appear.  

 

• Type the text to be hidden under the cell  

 

The dialogue box will close down, leaving you in the cell. 
The cell will show a small red tag in the top right corner.  

 

READING THE NOTE 

• When you position the white cross over the cell the note will appear 

DELETING THE NOTE 

• Right click on cell then choose "Delete Comment" 
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SETTING PRINT TITLES 

It is useful to be able to repeat headings across and/or down a series of pages, 
particularly on a large Worksheet, e.g. a database. 
 
You can set the Sheet to print headings for both the columns and rows of the 
Worksheet. From inside the Sheet: 
 
• Click on “File” in the menu bar, then “Page Setup” and select “Sheet” 

• In the “Print Titles” area, click inside the “Rows To Repeat At Top” or 
“Columns To Repeat At Left” sections. 

 

• On your Worksheet, click on the rows or columns to be set as side or heading 
titles. The reference will be entered in the box. 
 

• Click on “OK”  

 

From now on, each time you print, the titles for the columns or rows (or both) will appear 
on all pages of the document. 

 

If you are selecting a particular area to print, there is no need to include the Print 
Titles area, it will print automatically. 



www.ebitsolutions.net     JANUARY 2000 EBIT SOLUTIONS LIMITED 
 

 
18 EXCEL 2000 INTERMEDIATE USER MANUAL 

 



EBIT SOLUTIONS LIMITED JANUARY 2000 

 

 
EXCEL 2000 INTERMEDIATE USER MANUAL 
IT Support London 

Free Microsoft Office Training Manuals 19 

TEMPLATES 

A Template is a mastercopy of a standard Worksheet, it allows you to create a 
Workbook in a standard individualised or department format which has the same layout 
in each Sheet, uses the same formulae, has the same style, presentation etc. 
Templates are stored independently from normal Workbooks, and have a different suffix 
“.XLT”.  

TO CREATE A TEMPLATE 

• Create a new Workbook in the style and format you wish to have as your 
standard setup 

Go on to Save the Workbook.  Within the “Save As” dialogue box name the file then 
make the following changes: 

• Click on the down arrow to the right of the  “Save File As Type” box and select 
“Template”. The Workbook will acquire an .XLT extension. 
 

• Change the directory to 
“C:\excel\xlstart” or, if you have 
MS Office 
“C:\msoffice\excel\xlstart” 
 

• Click on “OK” 

 

 

 

You have created your Template and can take copies of it - without affecting the original 
document - as frequently as you wish. 

USING THE TEMPLATE 

You can use the Template by creating a new Workbook based on the Template.  This 
Workbook is a copy of the template that is treated like a standard new Workbook and 
will need to be saved with a name, into a drive and directory. 

• Click on “File” in the menu bar, then click on “New” 
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A dialogue box will appear, displaying your 
template name(s) 
 
• Click on the name of the template 

you want, then click on “OK” 

A copy of the template will appear on 
screen, you can work on it and save it in 
the normal way. 
 

 

 

The changes you make here do not affect the actual template. 
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EDITING TEMPLATES 

You may, at some point wish to make changes to your Template(s). 

To Open The Template And Edit It 

 

• In the “File” menu, choose “Open” 

• Change the directory to “C:\program files\msoffice\templates” 

• Select the name of Template you want to Edit, then click on “OK” 

 
This allows you to open the original Template as opposed to taking a copy.  Once you 
have finished editing, save and close the Template. 
 

For Terminal Server IT will have to alter the Templates 
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DATABASE FUNCTIONS 

A Database is a collection of information arranged in a structured way, which can then 
be manipulated to extract data or perform calculations.  Excel can be used to create and 
manipulate simple databases.  It is particularly appropriate where calculations are 
involved. 

Databases should be set up in one Sheet where the information is arranged in one large 
block, with no empty rows or columns appearing within the data block.  The top row of 
the block should contain headings describing the data that is stored in each column.  
Each subsequent row of data then represents a ‘Record’.   

Extra information that is not a part of the database, can be stored in the same Sheet.  
But there should always be a gap of at least one empty cell between cells in the data 
block and any extra information stored in the Sheet. 

CREATING A DATABASE 

A database is created on a single Sheet 

• The top row of the block must contain headings for each column of data 

 

• Below the headings type the information relating to the individuals, companies 
etc. on whom the database is founded. This is called a ‘Record’. 

 

• You can leave individual cells empty, but you must not leave any completely 
empty rows or columns in the block of data, otherwise Excel will not act on all 
your data when you start to use the Excel database features 

 

☺TIP  
You can test to see if the data has been set up correctly: Click in a cell in the 
data and press the shortcut command [Ctrl]+[Shift]+*.  This shortcut selects 
the current array.  The cells that are selected are the only ones that will be 
acted upon when you start to Sort or Filter your database. 
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MOVING AND SELECTING IN AN EXCEL DATABASE 

There are some keyboard shortcuts for moving around or selecting cells in Excel that 
are especially useful when working with a database. 

MOVING AROUND 

Keyboard Command Result 

Ctrl+Ð Moves down to the end of the current data region 

Ctrl+Ï Moves up to the end of the current data region 

Ctrl+Î Moves right to the end of the current data region 

Ctrl+Í Moves left to the end of the current data region 

Home Moves to the beginning of the current row 

Ctrl+Home Moves to cell A1 

The Ctrl+Arrow commands will move you to the beginning or end of your data as long as 
there are no empty cells in the direction you are moving. 

 

SELECTING DATA 

The Shift key can be used to extend a selection.  Here it is combined with the movement 
shortcuts to move and select at the same time. 

Keyboard Command Result 

Ctrl+Shift+Ð Selects down to the end of the current data region 

Ctrl+ Shift+Ï Selects up to the end of the current data region 

Ctrl+ Shift+Î Selects right to the end of the current data region 

Ctrl+ Shift+Í Selects left to the end of the current data region 

Ctrl+Shift+* Selects the current array (the data block) 

The Ctrl+Shift+Arrow commands will select to the beginning or end of your data as long 
as there are no empty cells in the direction you are selecting. 
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FORMS 

You can build or edit your database by moving around the spreadsheet cells and 
entering new data or editing the existing cell contents, as you would normally in a 
spreadsheet.  However in large databases it can get quite difficult to locate existing 
records (rows of data) and add new data. 

The Forms feature is designed to help you to maintain your database by generating a 
‘Form’.  The Form displays each row of data in your database as a record, one record at 
a time. 

Using the Form you can add new records, delete records which are no longer 
applicable, change the details in a record and look for specific records. 

To Use Forms 

• Click on one cell in your data 

• Click on “Data” in the menu 
bar 

• Click on “Form” 

 
The following screen will appear: 

 
 
You can use the buttons on the right hand side to maintain the Database: 
 

New Lets you to add another record to your Database by 
presenting you with a blank record to complete with new 
information. 

Delete Will delete the full record displayed at the time. 

Restore Restores a record’s original details if changes are made in 
error. 

Find Prev/Next Will jump you to the previous record or next record. 

Criteria Enables you to look for a record by inserting the text to look 
for in the relevant field and then clicking on the Find Prev 
button. 
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SORTING DATA 

The data in your database can be sorted into alphabetical or numerical order.   

Sorting data is very easy, but care must be taken to do it the correct way.  If data is 
sorted the wrong way then the whole database can become scrambled. 

If you have a row of totals at the bottom of your data, you should either delete them 
before you start sorting data, or insert an extra row above the totals to separate them 
from the database. 

To Sort Data 

• Click on any one cell in the column you wish to sort by 

DO NOT click on the column heading to select the whole column 

• Click on the “Sort Ascending” button  
(A to Z) to sort text alphabetically from A to 
Z, or numbers from the lowest number to the 
highest 

or 

Sort
Descending

Sort
Ascending

 

• Click on the “Sort Descending” button (Z to A) to sort text alphabetically from Z 
to A, or numbers from the highest number to the lowest  

The whole database will be sorted on that criteria. 

 

MULTILEVEL SORTING 

You can perform a Multilevel sort without having to go through the Data menu (see next 
section).  The trick is to sort each level in reverse. 

For example if you have a list of employees that you would like to be sorted by surname 
and then by first name - Sort by first name first, then sort by surname.  Excel does not 
change the order of data unless it has to, so the order of the first names will stay in the 
same position for all employees with the same surname. 
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SORTING THE DATABASE ON MULTIPLE CRITERIA 

• Click on any one cell in the column you wish to sort by 

DO NOT click on the column heading to select the whole column 

• In the “Data” menu, choose “Sort” 

This will bring up the Sort dialog box. 

 

• Click on the down arrow next to the “Sort By” field, a menu will appear 

• Click on the first field name you wish to sort by, e.g. “surname”, Then select 
“Ascending” or “Descending” - usually ascending order (A Z) 

 To sort by a second field within the first, e.g. by first name or initial: 

• Click on the down arrow next to the middle “Then By” field and from the menu 
select the second field 

• Repeat this action at the lower “Then By” field if you wish further refinement of 
the output by a third field 

• Click “OK” to perform the sort 

  

The selection will remain set for future sorts with this Sheet. To change it, either reset or 
empty the fields. 
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FILTERING A DATABASE 

The Filter feature enables you to display only the rows in a database that contain a 
certain value, or that meet a set of criteria.  You can filter by several different criteria at 
the same time.  Once the data has been filtered you can view it, print it, copy it or even 
create a graph from it. 

Creating A Filter 

• Click on any one cell in your database 

• In the “Data” menu in the menu bar, click on “Filter”, then “AutoFilter”.   

Drop down list arrows will appear next to the headings in your database. 

 

• Click on the drop down arrow on the field to be used as a filter.  A list will 
appear showing - in alphabetical order - all possible choices held in that column 
of the database.  

• From the list choose your selection criteria 

As soon as you select a criteria the database will change to reflect your choice.  It will 
display only the records containing the selected criteria.  All the other rows, that do not 
satisfy the selected criteria, are hidden from view.   

You will notice that the drop down arrow turns blue when data is being filtered by a 
criteria in that column. 

You can repeat this for another selection on a second criteria, so that the data is filtered 
by two criteria at once.  But, if you select two filter criteria that are mutually exclusive 
then no data will be displayed.  E.g. if you choose to display all ‘Female’ staff that have 
the ‘First Name’ John, the filter will probably not find any data. 

To Retrieve All Your Records 

• Click on the drop down arrow in each field heading that is being filtered, then 
select the “(All)” option at the top of the list 

or 

• In the “Data” menu, choose “Filter”, then click on “Show All” 
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CREATING A CUSTOM FILTER 

A normal filter displays all data that is equal to the criteria you choose in the drop down 
list.  But if you wish to filter data by a column that contains numbers, you might want to 
display all data that is greater than, or less than a certain value.  The Custom filter option 
allows you to do this. 

To Customise A Filter 

• Turn on the AutoFilter feature 

• Click on the drop down arrow on the field to be used as a filter, and in the drop 
down list select “(Custom)” 

This will bring up the Custom AutoFilter dialog box.   The two rows of input boxes allow 
you to set up to two filter criteria on the same field. 

 

• Select a relationship in the 1st  box  

• Enter a value in the 2nd  box 

If you want to create a second criteria, you can add another value and relationship in the 
second set of input boxes.  Then select “And” to filter data that satisfy both criteria or 
select “Or” to filter data that satisfy one criteria or the other. 

• Click “OK” to filter the data 

 

To Remove The AutoFilter 

• In the “Data” menu choose “Filter”, then select “AutoFilter” 

The filter is switched off. 
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SUBTOTALLING DATA 

Excel databases can be subtotalled to display a subtotal row at each category change in 
the column you select and a Grand Total row at the bottom of the data.   

You can also calculate averages, or run a count for each category in the data. 

It is important to sort your list by the column you wish to create the subtotals for, before 
you create subtotals.  Your data must also have column headings in the first row. 

To Subtotal Data 

• Click on any one cell in the data 

• In the “Data” menu choose “Subtotals” 

This will bring up the Subtotal dialog box. 

• In the “At Each Change In” 
drop down menu, select the 
field that you wish to subtotal 
by 

• In the “Use Function” drop 
down menu, choose the 
Function you would like to 
apply to category, e.g. Sum, 
Average, Count 

• In the “Add Subtotal To” list 
select the columns of data that 
you would like to apply the 
selected Function to 

• Click “OK” 

 

  

When Subtotals have been applied to data, 
you can collapse the data down to display 
only the subtotal rows, using the grey 
numbered control boxes to the left of the 
data. 

• Click on box number 1 to display only 
the Grand Total 

• Click on box 2 to display only the 
Subtotals 

• Click on box 3 to display all the data  
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To Remove Subtotals 

• In the “Data” menu choose “Subtotals” 

• In the Subtotals dialog box click on the “Remove All” button 

AUTOFORMAT 

The AutoFormat feature automatically applies a built-in combination of formats to a 
range of cells or a data table.  Microsoft Excel provides a variety of autoformats that 
apply formats for numbers, alignments, fonts, borders, patterns and shading, column 
width, and row height.  

AutoFormat is especially useful for applying formats to data that has been Subtotalled, 
as it will apply a different set of formats to all the subtotal rows to differentiate them from 
the rest of the data. 

To Apply Autoformatting 

• Click on any one cell in the data 

• In the “Format” menu choose “AutoFormat” 

This will bring up the AutoFormat dialog box. 

 

• In the list of Table Formats, select a format 

A Sample of that format style will be appear. 

• Click “OK” 

 

 

Deleting Formatting 

You can remove formatting from cells without removing the data contained in the cells. 

• Select the cells 
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• In the “Edit” menu choose “Clear”, then select “Formats” 
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SPLITTING THE SCREEN 

If you are working on a large spreadsheet you may wish to see different parts of the 
same sheet at the same time.  You can do this by splitting the screen. 

You can split the screen into two horizontal segments, two vertical segments or you can 
apply both splits at once to create four segments. 

 

To Split The Screen Horizontally 

Just above the up arrow button at the top of the Vertical scroll bar is a small 
grey bar.  This is the control used to split the screen horizontally.  

 
• Click on the grey control bar and drag down the screen 

The screen will now be split into two segments, with a grey split line separating both 
parts.  Each segment has its own set of up and down controls on the vertical scroll bar, 
allowing you to scroll to different parts of the same sheet. 

 

To Split The Screen Vertically 

Just after the right arrow button at the end of the Horizontal scroll bar is a 
small grey bar.  This is the control used to split the screen vertically. 

 
 

• Click on the grey control bar and drag left across the screen 

The screen will now be split into two vertical segments.  Each segment has its own set 
of left and right controls on the horizontal scroll bar, allowing you to scroll to different 
parts of the same sheet. 

 

To Move A Split 

• Click on the split line running across the screen and drag up, down, left or right 
as required 

 

To Delete A Split 

• Double click on the split line 
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CREATING MULTIPLE CHARTS 

It is possible to use the Chart Wizard to create multiple charts without having to create 
each chart from scratch.   

The trick is to create the first chart and format it the way you would like all the charts to 
look.  You then copy the original chart to create the next chart, and then redefine the 
chart data. 

 

To Create Multiple Charts 

• Create the first chart using the Chart Wizard, and size and format it the way you 
would like all the charts to look 

• Click once to select the chart 

• Click on the “Copy” button 

• Deselect the chart by clicking on an empty cell where you want to paste the new 
chart to 

• Click on the “Paste” button  

• Resize the copy if necessary  

You now need to redefine the data for the new chart. 

 

To Redefine Chart Data 

• Click once to select the new chart 

• Click on the “Chart Wizard” button 

This will bring up the Chart Wizard dialog box.  But this time it contains only two steps.  
The first step allows you to choose the data range being used by the chart. 

• With the Chart Wizard dialog box still showing on the screen, click and drag 
through the spreadsheet cells to select the new data 

You may need to move the dialog box out of the way by clicking and dragging on its blue 
title bar. 

• Click on the “Finish” button 

You can then repeat this process to create each additional chart. 

 

☺TIP  You can use the Ctrl key to select two separate ranges of cells at the same 
time.  (This can be useful for creating multiple charts, especially multiple pie 
charts).  Select the first range, then hold down the Ctrl key as you select each 
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subsequent range. 

 


